chiron on mono

Oct 16, 2008 at 1:02 PM
just wondering whether chiron is expected to work on mono.

i'm running mono 2.0 on os x 10.5 and get the following error when creating the xap file:

Macintosh:dlrconsole markryall$ pwd
/downloads/sdlsdk-0.4.0/samples/dlrconsole
Macintosh:dlrconsole markryall$ mono ../../bin/chiron.exe /w
Microsoft(R) Silverlight(TM) Development Utility. Version 1.0.0.0
Copyright (c) Microsoft Corporation.  All rights reserved.

Chiron serving '/downloads/sdlsdk-0.4.0/samples/dlrconsole' as http://localhost:2060/
00:01:25 200     2,242 /index.html
00:01:25 200     2,397 /stylesheets/error.css
00:01:26 500       673 /app.xap [error generating XAP: libMonoPosixHelper.dylib]

... perhaps this is just an odd thing to want to do.
Coordinator
Oct 17, 2008 at 12:38 AM

Chiron should definitely work on mono. What version of mono is this, 2.0?

From: markryall [mailto:notifications@codeplex.com]
Sent: Thursday, October 16, 2008 6:03 AM
To: Jimmy Schementi
Subject: chiron on mono [sdlsdk:37861]

From: markryall

just wondering whether chiron is expected to work on mono.

i'm running mono 2.0 on os x 10.5 and get the following error when creating the xap file:

Macintosh:dlrconsole markryall$ pwd

/downloads/sdlsdk-0.4.0/samples/dlrconsole

Macintosh:dlrconsole markryall$ mono ../../bin/chiron.exe /w

Microsoft(R) Silverlight(TM) Development Utility. Version 1.0.0.0

Copyright (c) Microsoft Corporation. All rights reserved.

Chiron serving '/downloads/sdlsdk-0.4.0/samples/dlrconsole' as http://localhost:2060/

00:01:25 200 2,242 /index.html

00:01:25 200 2,397 /stylesheets/error.css

00:01:26 500 673 /app.xap [error generating XAP: libMonoPosixHelper.dylib]

... perhaps this is just an odd thing to want to do.

Read the full discussion online.

To add a post to this discussion, reply to this email (sdlsdk@discussions.codeplex.com)

To start a new discussion for this project, email sdlsdk@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Oct 18, 2008 at 4:01 AM
Found the problem:

I'd installed mono via macports (sudo port install mono).

I downloaded the mac os x build of mono 2.0 (with cocoa# etc.), made sure it's on the path and Chiron's now working a treat.